Introducing RxJS6! - Ben Lesh

Поделиться
HTML-код
  • Опубликовано: 28 янв 2025

Комментарии • 17

  • @js_pathfinder
    @js_pathfinder 6 лет назад +2

    Great talk, thanks! RxJS is awesome! :)

  • @JakovljevicMladen
    @JakovljevicMladen 5 лет назад

    What's that syntax at 8:00? Why is he not using `{error: (err) => {...}}` ?It's obvious that `{error(err) {...}}` would work, but how is this syntax called? It looks more like a class/method declaration than an object? Is that also part of destructuring?

  • @TT-ud5gf
    @TT-ud5gf 6 лет назад

    At 6:13, the video shows badSource$.subscribe(...). Is badSource an object name and why does it have the $ symbol?

    • @AsFunAsFunDev
      @AsFunAsFunDev 6 лет назад +1

      Just a convention, It is from cycle.js .. cycle.js.org/basic-examples.html#basic-examples-increment-a-counter-what-is-the-convention
      I prefer just to call something an observable.

    • @jounisuorsa5786
      @jounisuorsa5786 6 лет назад +1

      Seems to be called Finnish notation .. medium.com/@benlesh/observables-and-finnish-notation-df8356ed1c9b

  • @jeanfrancoischautard7881
    @jeanfrancoischautard7881 6 лет назад +1

    Excellent !

  • @beeeeeeeeeeep
    @beeeeeeeeeeep 6 лет назад +1

    Amazing talk, thanks!

  • @DavidConnerCodeaholic
    @DavidConnerCodeaholic 6 лет назад

    but does igor do handstand pushups?

  • @seekheart2023
    @seekheart2023 6 лет назад

    Where can I get the slide theme? The mac like UI look is cool!

  • @ahahn928
    @ahahn928 6 лет назад

    Where are the docs for v6 located?

  • @webmote31
    @webmote31 6 лет назад

    very good!

  • @mikebarger
    @mikebarger 6 лет назад +9

    Don’t you think it is a bad practice to introduce functions that aren’t scoped to a class like the new “of” function. If every library creator followed your example it would make a mess of name collisions and forced aliases. At least when you hang these functions off a class it reduces the name collisions to just class names? “of” seams like one of those names that is almost certainly going to become a keyword in the future. Hanging these functions off a class also helps the developer with intellisense instead of having to memorize the names of this function soup. Again, this might not be so bad if this is done with one library, but if we all followed your pattern, the javascript ecosystem would certainly be worse off.

    • @algife
      @algife 6 лет назад

      IMHO, "observe" instead of "of" would be better, more descriptive and would make less potential collissions. Said that, good work team!

    • @FredoCorleone
      @FredoCorleone 5 лет назад +2

      import { of: whateverYouWannaCallIt } from 'rxjs';

  • @Dragiux
    @Dragiux 6 лет назад +1

    You're not exclaiming the most important note: Don't update dependencies in production unless you absolutely have to.