How to configure RSTP and MST in Cisco switch? | labeveryday part 60 using CML Cisco Devnet Sandbox

Поделиться
HTML-код
  • Опубликовано: 30 ноя 2024

Комментарии • 1

  • @mariembuenaventura1278
    @mariembuenaventura1278  3 года назад +4

    TASK0::setup CML multiple tabs via putty.
    !add enable password to each network device.
    !ubuntu username:ubuntu , password:cisco
    TASK1::create VLANs from L3SW1
    VLAN10 - IT
    VLAN20 - HR
    VLAN30 - QA
    VLAN100 - TEST1
    VLAN200 - TEST2
    VLAN300 - TEST3
    TASK02::add trunkports
    TASK03::setup VTP version 3 on all L3SW
    vtp domain CISCO.COM
    vtp password CISCO
    vtp version 3
    vtp pruning on
    TASK04::add RSTP and L3SW1 as the primary root bridge
    TASK05::add MST instance 1 as VLAN1- 99 and
    instance 2 as VLAN 100 - 500
    ----------------------------------------------------
    TASK0::add basic commands to each network device.
    To all network devices::SYNTAX
    enable
    conf t
    !edit hostname here*****************************
    hostname L3SW5
    no ip domain-lookup
    !edit username here******************************
    username ADMINL3SW5 password CISCO
    enable password CISCO
    line console 0
    no logging synchronous
    !for lab environment online then set 0 0 in the production
    exec-timeout 0 0
    login local
    exit
    line vty 0 4
    login local
    transport input ssh
    exec-timeout 0 0
    exit
    ip domain-name cisco.com
    crypto key generate rsa
    1024
    ip ssh version 2
    exit
    wr
    ---------------------------------------
    TASK1::create VLANs from L3SW1
    VLAN10 - IT
    VLAN20 - HR
    VLAN30 - QA
    VLAN100 - TEST1
    VLAN200 - TEST2
    VLAN300 - TEST3
    L3SW1::
    conf t
    vlan 10
    name IT
    exit
    vlan 20
    name HR
    exit
    vlan 30
    name QA
    exit
    vlan 100
    name TEST1
    exit
    vlan 200
    name TEST2
    exit
    vlan 300
    name TEST3
    exit
    show vlan brief
    -----------------------------------
    TASK02::add trunkports to L3SW
    L3SW1::
    conf t
    interface range giga 0/1 - 1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    interface range giga 1/1 - 2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    show interfaces trunk
    L3SW2::
    conf t
    interface giga 0/0
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    L3SW3::
    conf t
    interface giga 0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    end
    show interfaces trunk
    L3SW4::
    conf t
    interface giga 1/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    end
    show interfaces trunk
    L3SW5::
    conf t
    interface giga 1/2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    end
    show interfaces trunk
    ----------------------------------
    TASK03::setup VTP version 3 on all L3SW
    vtp domain CISCO.COM
    vtp password CISCO
    vtp version 3
    vtp pruning on
    L3SW1::
    conf t
    vtp mode server
    vtp domain CISCO.COM
    vtp password CISCO
    vtp version 3
    exit
    show vtp status
    vtp primary vlan
    L3SW2-5::
    conf t
    vtp mode client
    vtp domain CISCO.COM
    vtp password CISCO
    vtp version 3
    exit
    show vtp status
    show vlan brief
    !add vtp mode transparent to L3SW2-5
    vtp mode transparent
    ----------------------------------
    TASK04::add RSTP and L3SW1 as the primary root bridge
    L3SW1::
    conf t
    !set vlan 10 as root, vlan 20 as secondary
    spanning-tree mode rapid-pvst
    spanning-tree vlan 10 root primary
    spanning-tree vlan 20 root secondary
    L3SW2::
    conf t
    !setup vlan 20 as root, vlan 30 as secondary
    spanning-tree mode rapid-pvst
    spanning-tree vlan 20 root primary
    spanning-tree vlan 30 root secondary
    exit
    show spanning-tree
    L3SW3::
    conf t
    !setup vlan 30 as root, vlan 100 as secondary
    spanning-tree mode rapid-pvst
    spanning-tree vlan 30 root primary
    spanning-tree vlan 100 root secondary
    exit
    show spanning-tree
    L3SW4::
    conf t
    !setup vlan 100 as root, vlan 200 as secondary
    spanning-tree mode rapid-pvst
    spanning-tree vlan 100 root primary
    spanning-tree vlan 200 root secondary
    exit
    show spanning-tree
    L3SW5::
    conf t
    !setup vlan 200 as root, vlan 300 as secondary
    spanning-tree mode rapid-pvst
    spanning-tree vlan 200 root primary
    spanning-tree vlan 300 root secondary
    exit
    show spanning-tree
    --------------------------------------------------
    TASK05::add MST instance 1 as VLAN1- 99 and
    instance 2 as VLAN 100 - 500
    L3SW1::
    conf t
    spanning-tree mode mst
    spanning-tree mst configuration
    instance 1 vlan 10-99
    instance 2 vlan 100-500
    exit
    spanning-tree mst 1 root primary
    spanning-tree mst 2 root secondary
    L3SW2::
    conf t
    spanning-tree mode mst
    spanning-tree mst configuration
    instance 1 vlan 10-99
    instance 2 vlan 100-500
    exit
    spanning-tree mst 1 root primary
    spanning-tree mst 2 root secondary
    exit
    show spanning-tree mst 1
    show spanning-tree mst 2
    L3SW3::
    conf t
    spanning-tree mode mst
    spanning-tree mst configuration
    instance 1 vlan 10-99
    instance 2 vlan 100-500
    exit
    spanning-tree mst 1 root primary
    spanning-tree mst 2 root secondary
    exit
    show spanning-tree mst 1
    show spanning-tree mst 2
    L3SW4::
    conf t
    spanning-tree mode mst
    spanning-tree mst configuration
    instance 1 vlan 10-99
    instance 2 vlan 100-500
    exit
    spanning-tree mst 2 root primary
    spanning-tree mst 1 root secondary
    exit
    show spanning-tree mst 1
    show spanning-tree mst 2
    L3SW5::
    conf t
    spanning-tree mode mst
    spanning-tree mst configuration
    instance 1 vlan 10-99
    instance 2 vlan 100-500
    exit
    spanning-tree mst 2 root primary
    spanning-tree mst 1 root secondary
    exit
    show spanning-tree mst 1
    show spanning-tree mst 2
    show spanning-tree summary