The fact that it's shallow is something that I just *KNOW* will come to bite me. Generally when the caffeine has worn off and the brain is going into power-saving mode.
i think the idea here is that your classes are immutable. replace only really useful in this case, it’s a functional construct, so shallow copying shouldn’t be an issue because the data won’t be mutable anyway
I think it has been around for as long as dataclasses have existed. It definitely exists in 3.10 anyway. But perhaps this more generalised version of replace is intended to replace (pun intended) the one in the dataclasses module.
@ZelenoJabko languages "steal" from other languages all the time. It's nothing new. It's actually a very positive and healthy thing. Again, I'm glad to see Python "stealing" this feature as I think it can be very useful. I know I used C#'s version of it recently in a project and it was great.
This is not for changing values of immutable objects, if you want a mutable dataclass for instance, you just don't set frozen to true. The use case for this method is when you want to create a second immutable object that is similar to the first but slightly different. Since the object is immutable, you cannot make a copy and change it. Replace helps you create a copy that is different in the keys that you specify but still the same in all other properties and also immutable.
I've already answered another person who also didn't like the name, so I'll just copy my opinion here. A name like replaced() would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() (or copy_and_replace()) would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead, so there's probably no need for verbose names.
Clear and Concise, that is why I always keep my self up to date with the new python release. But I try to not forget the old one as most of the code will be in old version.
@@e-pluszak9419 or another common trick with currency is to store it in terms of the smallest denomination and you always have a integer, e.g. for USD store an integer number of cents, or for GBP store an integer number of pence.
I don't use python much but from those examples I don't see the difference of using NamedTuple and dataclasses, what's the difference? Edit ah dataclasses are mutable by default, frozen=true makes them immutable. What's the difference then
The fields in a named tuple may be accessed either by name or by index. Before named tuples existed functions such as os.stat() simply returned a ten element tuple. It still returns a ten element tuple for compatibility with old code but these days you wouldn't think of using anything but the named fields. Dataclasses are simply classes so they don't have any of the tuple baggage.
@@DuncanBooth So why would anyone use Frozen dataclasses if they are less permissive? I assume NamedTuples are faster too because c implementation and not dictionnary Edit: Actually, Maybe for typing it's good, because tuple NamedTuple1(x=1, y=2) == NamedTuple2(x=1, y=2) But Dataclass1(x=1, y=2) and Dataclass2(x=1, y=2) are different
@@Kynatosh Mutability may result in ugly bugs, and using less permissive structures is recommended for a similar reason. You want to make as restricted and deterministic as possible your code.
Yeah, I get it, it would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead.
@@rubynaxela8524always remember that new people are joining the field all the time and are learning Python for the first time. Consistency in naming is very important. Old hats will adapt but newbies will still be confused. Unfortunately I don't think Python language developers put near enough time into thinking about names and the inconsistency shows. So the distinction between replace and replaced or with_replaced is an important discussion that Python lang devs should have had.
If your class is as simply as Point, sure. If your class is big and complex you can make a deepcopy() and then change whatever attribute you need, but replace is more readable I guess
nah I am not in a profession nor do I ever desire to casually use a statically typed language, but I still watch videos about them because peeks at language design is still interesting. People love tourism shows even if they’ll never travel.
The fact that it's shallow is something that I just *KNOW* will come to bite me. Generally when the caffeine has worn off and the brain is going into power-saving mode.
i think the idea here is that your classes are immutable. replace only really useful in this case, it’s a functional construct, so shallow copying shouldn’t be an issue because the data won’t be mutable anyway
@@prepsure_yep you needed to have fucked up twice already if you're running into data consistency problems using immutable type classes 😂
There is a method dataclasses.replace (in Python 3.12 at least) - for dataclasses copy.replace is not needed
I think it has been around for as long as dataclasses have existed. It definitely exists in 3.10 anyway. But perhaps this more generalised version of replace is intended to replace (pun intended) the one in the dataclasses module.
There is also the method NamedTuple._replace. Does this new method do anything that can’t already be done?
@@fyellinit bacically unifies all the different replace methods with introduction of __replace__
@@martinpayne2934 since 3.7
The RUclips algorithm has got you
This is essentially the "with" keyword in C#. Glad to see Python getting this feature!
c# stole this feature from Scala.
@ZelenoJabko languages "steal" from other languages all the time. It's nothing new. It's actually a very positive and healthy thing. Again, I'm glad to see Python "stealing" this feature as I think it can be very useful. I know I used C#'s version of it recently in a project and it was great.
@@ZelenoJabkoevery language steals from lisp 💀
@@ZelenoJabko and Scala stole it from OCaml
I mean. The dataclasses module itself already has a replace function that works like that.
What is the difference compared to using cup.copy(price=100) ?
Really clear and useful, thank you
Python 3.13 has some good features, and I wanna learn it all!! But I still don't know most of the features of the past versions 😭😭😭😭
I didn't even know about dataclasses. Thanks.
You must
Naming a package just "copy" is pure evil.
Nice feature!
"what am I even saying" 😂😂😂
Can you please show some Pytest examples and features, please.
3:08 why use replace when you can just make a new instance?????
It would be more useful if the class had many you want to keep the same
its super useful if you decide everything to be inmutable, which is common in functional programming
That's just an example, real dataclass could have more fields than that
Genuinely, why would you change the value of an immutable object in a first place ? I mean, isn't there any dynamic data structure in python ?
This is not for changing values of immutable objects, if you want a mutable dataclass for instance, you just don't set frozen to true. The use case for this method is when you want to create a second immutable object that is similar to the first but slightly different. Since the object is immutable, you cannot make a copy and change it. Replace helps you create a copy that is different in the keys that you specify but still the same in all other properties and also immutable.
Thanks for the video :)
I want to use 3.13 but too many packages have dependency issues still (I use miniconda for data wranglingstuff).
Keep going... [for other whatever topics]
Amazing as always
I like the feature, but don't really love the name. "replace" means replace, not "copy and replace". At least in my head.
I've already answered another person who also didn't like the name, so I'll just copy my opinion here.
A name like replaced() would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() (or copy_and_replace()) would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead, so there's probably no need for verbose names.
i would have called it new_from.
but i also don't know anything about Python naming conventions.
That's actually good.
So why isn't there a deep_replace the same way there is a deep_copy?
Anyone knows in what case this might be useful ?
this is HUGE
Clear and Concise, that is why I always keep my self up to date with the new python release. But I try to not forget the old one as most of the code will be in old version.
your IDE be like: I don't know what you mean
Thanks
Price of type float, ouch 😳
If your country doesn’t have coins you can always use an integer.
@Indently yes, but if it does using floats is still insane due to rounding errors, Decimal class is the way to go
@@e-pluszak9419 or another common trick with currency is to store it in terms of the smallest denomination and you always have a integer, e.g. for USD store an integer number of cents, or for GBP store an integer number of pence.
I don’t understand what the real world use case for this would be
I don't use python much but from those examples I don't see the difference of using NamedTuple and dataclasses, what's the difference?
Edit ah dataclasses are mutable by default, frozen=true makes them immutable. What's the difference then
The fields in a named tuple may be accessed either by name or by index. Before named tuples existed functions such as os.stat() simply returned a ten element tuple. It still returns a ten element tuple for compatibility with old code but these days you wouldn't think of using anything but the named fields.
Dataclasses are simply classes so they don't have any of the tuple baggage.
@@DuncanBooth So why would anyone use Frozen dataclasses if they are less permissive? I assume NamedTuples are faster too because c implementation and not dictionnary
Edit:
Actually, Maybe for typing it's good, because tuple NamedTuple1(x=1, y=2) == NamedTuple2(x=1, y=2)
But Dataclass1(x=1, y=2) and Dataclass2(x=1, y=2) are different
@@Kynatosh "Less permissive" doesn't mean "less usable" -- tuples are less permissive than lists and both have their uses.
@@Kynatosh Mutability may result in ugly bugs, and using less permissive structures is recommended for a similar reason. You want to make as restricted and deterministic as possible your code.
cool
Should be called replaced instead of replace imo
Hmmm, and copy would be copied? I think I see your point (which you did not explain), but I think replace is just fine as well.
Yeah, I get it, it would be probably more consistent with functions like sorted() or reversed(). However that name could also suggest that we're somehow replacing the object itself, and not values of some of its fields, so perhaps a name like with_replaced() would be even more transparent. But I think that at this point everyone has learned that Python functions (global or static, not instance methods!!), by convention, never modify their arguments and return modified, new objects instead.
@@rubynaxela8524always remember that new people are joining the field all the time and are learning Python for the first time. Consistency in naming is very important. Old hats will adapt but newbies will still be confused. Unfortunately I don't think Python language developers put near enough time into thinking about names and the inconsistency shows. So the distinction between replace and replaced or with_replaced is an important discussion that Python lang devs should have had.
You might want to write `golden_cup = replace(deepcopy(cup), cost=100)`
Or `... deepcopy(replace( ...`
Thank you 😊
why can't we just do:
point1 : Point = Point(x=1, y=1)
point2 : Point = Point(x=5, y=1)
???
If your class is as simply as Point, sure. If your class is big and complex you can make a deepcopy() and then change whatever attribute you need, but replace is more readable I guess
❤❤❤❤
kinda reminds me of Cell in Rust
Is it weird that I Watch these Python vids even tho I use Lua?
No, I mainly use rust
nah I am not in a profession nor do I ever desire to casually use a statically typed language, but I still watch videos about them because peeks at language design is still interesting. People love tourism shows even if they’ll never travel.
local myAnswer = setmetatable({}, {
__tostring = function() return "yes" end
})
print(tostring(myAnswer))
The best thing about rust is converting strings to strings and u/isize to i32/64 and getting a panic error
Das ist verwirrend. warum nicht copy.replace?
Einfach nur ein andere Art des imports?
@@MrKerim2000 Ahh ok. replace wird ja von copy importiert und ist kein neues eigenes schlüsselwort. habe ich beim ersten schauen übersehen.
Danke dir